Recent Forum Posts
From categories:
page 1 of 212next »

Hello everyone. I have a question regarding FSP. My goal is to model a rail system and I have as main actors: the cabin of train control and signaling system to the ground. I wrote this code FSP, but it is all in a single process called ENGINE how do I separate them? I want to do this to enable the display of graphics LTS (I have been too many to view them with LTSA) and exploit the potential of the tool that allows concurrent software

Here is the code FSP:

const MAX_DIST = 5
range DIST = 0..MAX_DIST
const MAX_SEC = 12
range SEC = 0..MAX_SEC
const MAX_VEL = 5
range VEL = 1..MAX_VEL

ENGINE = (engineOn ->THROTTLE),

| engineOff ->ENGINE


SPEED_COUNTER[v:VEL] = ( when(v<MAX_VEL) accelerator[v] ->SPEED_COUNTER[v+1]
| when(v>1) reduceSpeed[v-1] ->SPEED_COUNTER[v-1]
| engineOff ->ENGINE
| when(v>1) signal_received ->metri250->DISTANCE[MAX_DIST][v]
| csr ->beep->CSR[v][MAX_SEC]

CSR[v:VEL][s:SEC] =
|when(s==0) brake->SPEED_COUNTER[1]
|when(s>0)release -> CHECK_DISTANCE[MAX_DIST][v]
|signal_received -> release -> SPEED_COUNTER[v]

|when(d==0) brake->SPEED_COUNTER[1]
|when(d>0)csr ->beep->CSR[v][MAX_SEC]

|when(c==0) brake->SPEED_COUNTER[1]
|when(c>0) signal_received ->SPEED_COUNTER[v]

Thanks for any reply if you need more information contact me.

Sincerely Stefano

railway signaling systems by SteoFlorenceSteoFlorence, 08 Dec 2009 12:44

Thanks for the answer

Thats the order of the functions I call:

My assumption is as follows:
I think you do the parsing/compiling in a seperate thread / job ? Maybe the parsing/compiling is not yet finished when I already call doLiveness sothat doLiveness cannot work
But thats of course just an assumption as I cannot see into your code.

Many greetings

Re: Question about doLiveness by ArtanisArtanis, 30 Sep 2009 18:16

Hi and thanks for the question..
Do you call doParse(boolean updatePages) before compiling? I'm not sure it marks the assertions without a parse - although I may be wrong.
Unfortunately these few weeks have been extremely busy.
I will try to take a look later in the week.


Ive got a question about the functionality of the doLiveness method. If I call this function in my program right after intialising the fsp editor and compiling the fsp text nothing happens.
If I do the same manually, that means, open Editor, compile the fsp text und check one assertion, it works fine.
What is the difference between calling this function in the gui and in the program
I tracked the execution of these both approaches in the debugger and the only difference I ve noticed is as follows:
In the case I call it in the GUI: the variable property with the name of the assertion keeps its value all the time
In the case I call it in my program: the variable property loses its value after 2 or 3 steps and becomes ""

Whats the reason for this?


Many greetings

Question about doLiveness by ArtanisArtanis, 25 Sep 2009 20:23
Re: Api
ArtanisArtanis 21 Aug 2009 18:44
in discussion LTSA (Eclipse) Tool / Bug Reports » Api


My problem is not project specific. Sorry my English is no very good, but nevertheless I try it_:)

If I use your standalone ltsa tool I go to Check->LTL and choose one assertion. Everything works fine
If I take the same FSP text and use it in the LTSA eclipse plugin I cannot find this function. In the outline view no assertions is shown and there is no "check->ltl" option.

Many greetings

Re: Api by ArtanisArtanis, 21 Aug 2009 18:44

The perspective is now visible, thanks a lot for the new build! I'm running it on a 64 bit Cocoa version.
I tried checking a property of the seefm2007 example and seemed to work, even though the LTSA-BPEL editor reported some syntax errors.
I'll play a little more in the next days and let you know.

So you are running 64bit then? That might cause further issues…

Anyway, back on 32bit Eclipse 3.5 MAC OS X and I had more time to "grab a mac" to rebuild the projects… seems like an Execution Environment issue (so much for Technology Independence!).


I put this test build on a new update site here: MAC OSX WSE Install which appears to install ok.

Not everything is working correctly (SWT issues seem to be evident), but should let you play a bit further.

Very strange no error report at all…. btw. what version of Java are you running again?
WS-Engineer needs at least JRE 1.6

Re: Api
ltsaadminltsaadmin 31 Jul 2009 21:19
in discussion LTSA (Eclipse) Tool / Bug Reports » Api

can you attach or send me your sample model (LTS) and I will also try to recreate this.

Re: Api by ltsaadminltsaadmin, 31 Jul 2009 21:19
Re: Api
ArtanisArtanis 31 Jul 2009 11:52
in discussion LTSA (Eclipse) Tool / Bug Reports » Api

No i meant I dont find the function neither in the default custom LTSA editor nor in the original editor. The other view don't recognise any of my assertions :(

Re: Api by ArtanisArtanis, 31 Jul 2009 11:52

I've also tried with a vanilla installation of Eclipse 3.4.2 and LTSA/WS-Engineer from the official install site (not the experimental install35) and the problem is still there: LTSA works fine but the "LTSA WS-Engineer" perspective is not available in the list of available perspectives. The workspace error log does not contain any reference to the plugin.

Re: Api
ltsaadminltsaadmin 25 Jul 2009 21:24
in discussion LTSA (Eclipse) Tool / Bug Reports » Api

do you mean you could check assertions in the default LTSA editor, but not your own custom plug-in?
I will check the default custom plug-in…

Re: Api by ltsaadminltsaadmin, 25 Jul 2009 21:24
Re: Api
ArtanisArtanis 23 Jul 2009 13:31
in discussion LTSA (Eclipse) Tool / Bug Reports » Api

Ok I can do this, but its not a big deal ;)

But i have another problem. While developing my plugin I 've noticed that i cannot more check assertions. I dont find any options in the gui although i defined two assertions in the lts file? Have you removed this function?
doLiveness(nameOfAssertion) has no effect.

Many Greetings

Re: Api by ArtanisArtanis, 23 Jul 2009 13:31

should be something at least… try to send me your log file..
i.e. .\.metadata\.log file of your workspace.

Can you post anything related to WS-Engineer from the Error Log View on startup?

The 3.5 install site works now and I'm able to switch to the LTSA perspective and run LTSA. However, the "LTSA WS-Engineer" perspective is not listed in the list of available perspectives, even though the WS-Engineer plugin is reported in the Eclipse configuration details.

page 1 of 212next »
Unless otherwise stated, the content of this page is licensed under Creative Commons Attribution-Share Alike 2.5 License.